[fpc-pascal] Dosemu problems compiling

John Coppens john at jcoppens.com
Mon Apr 5 21:21:51 CEST 2010

Hello all,

After installing fpc 2.4.0 on a freedos directory, I had the following

- I tried to install using the install program, but dosemu crashed when
clicking on 'Continue'

- So I installed the base package manually, adjusted the path. Now fpc
(without arguments) starts correctly, showing all the commandline options.
Compiling a program (which compiled identically on Linux without errors),
I get a load of errors about GOTO and LABEL not being defined. 
I recompiled with -Sg, and dosemu crashed again.

I tried increasing DPMI memory (from 20 MB to about 50 MB), no difference.
The dosemu output is below.

Anyone had a similar experience?

(NOTE: I tried dosbox too. When I ran 'fpc', the screen output was
garbled. Tried several options, but couldn't get that to work).

I'm trying to get a program compiled for use under DOS+extender (or
win32). I looked up the possibility to cross-compile, but that doesn't
seem possible under x86_64 (no 32bit targets)?


ERROR: Fault handler re-entered! signal=11 _trapno=0xE
ERROR: cpu exception in dosemu code outside of DPMI client!
trapno: 0x0e  errorcode: 0x00000007  cr2: 0x00000000
eip: 0x004a2cc1  esp: 0x7fff16e2d270  eflags: 0x00010202
cs: 0x0033  ds: 0x013f  es: 0x013f  ss: 0x002b
ERROR: Please report the contents of ~/.dosemu/boot.log at
It would be even more helpful if would recompile DOSEMU and reproduce this
bug with "debug on" in compiletime-settings.
Page fault: write instruction to linear address: 0x00000000
CPU was in user mode
Exception was caused by insufficient privilege

More information about the fpc-pascal mailing list