[fpc-pascal] Move() vs MemCopy()

Marco van de Voort marcov at stack.nl
Tue Sep 29 15:51:16 CEST 2009

In our previous episode, Graeme Geldenhuys said:
> > No.
> So why is the function called MOVE instead of COPY?   :-)

Historical reasons apparantly. 
> I grep searched the *full* FPC source and found a implementation of
> MemCopy() in the packages/pasjpeg/* directory...  So it seems to
> confirm what you (Marco) said. MOVE = MEMCOPY.    It that case, MOVE
> is a pretty stupid and confusing name for a procedure that actually
> copies memory and not move memory. Just my 2c worth. ;-)

I've no idea what memcopy is, and why we should support it. Probably it is
some pascalized version of the standard C memcpy command.

Move is in use for 20 years, and I think it will generate 1000 times more
confusion than it will ever solve if you change or add to it.

More information about the fpc-pascal mailing list