[fpc-pascal] Move() vs MemCopy()

Graeme Geldenhuys graemeg.lists at gmail.com
Tue Sep 29 15:37:11 CEST 2009


2009/9/29 Marco van de Voort <marcov at stack.nl>:
>
> No.


So why is the function called MOVE instead of COPY?   :-)


I grep searched the *full* FPC source and found a implementation of
MemCopy() in the packages/pasjpeg/* directory...  So it seems to
confirm what you (Marco) said. MOVE = MEMCOPY.    It that case, MOVE
is a pretty stupid and confusing name for a procedure that actually
copies memory and not move memory. Just my 2c worth. ;-)

procedure MEMCOPY(dest, src : pointer; size : size_t);
begin
  Move(src^, dest^, size);
end;


Regards,
  - Graeme -


_______________________________________________
fpGUI - a cross-platform Free Pascal GUI toolkit
http://opensoft.homeip.net/fpgui/



More information about the fpc-pascal mailing list