[fpc-pascal] Breakpoints in certain procedure don't get hit.

Ken G. Brown kbrown at mac.com
Thu Jan 29 15:52:48 CET 2009

Yay! That seems to have worked.

At 10:17 AM +0100 1/29/09, fpc-pascal-request at lists.freepascal.org apparently wrote:
>Date: Thu, 29 Jan 2009 08:45:31 +0200
>From: Jonas Maebe <jonas.maebe at elis.ugent.be>
>Subject: Re: [fpc-pascal] Breakpoints in certain procedure don't get
>	hit.
>To: FPC-Pascal users discussions <fpc-pascal at lists.freepascal.org>
>Message-ID: <83CE8C91-7C3B-4B16-8ADA-F46B0352BC9E at elis.ugent.be>
>Content-Type: text/plain; charset=US-ASCII; format=flowed; delsp=yes
>On 29 Jan 2009, at 06:47, Ken G. Brown wrote:
>> In Xcode 3.1.2 I'm having trouble getting breakpoints to get hit in 
>> a certain procedure. Breaks in other procedures in the same file 
>> work. I can break before entering the procedure but 'step into' just 
>> executes the procedure that apparently has breakpoints correctly set 
>> but they don't get hit.  Tried complete clean and rebuild.
>Try changing the debug info from stabs into dwarf:
>In the project settings, under the Build tab, select the Debug 
>configuration, then the "All Settings" collection, filter on "fpc", 
>and add "-gw2" at the end of the FPC_SPECIFIC_OPTIONS settings. This 
>will switch the compiler from stabs to dwarf. Then clean and rebuild.

More information about the fpc-pascal mailing list