[fpc-pascal] GLext in Free Pascal does not work?

Jakub Marian kubazek at gmail.com
Wed Feb 20 23:00:24 CET 2008

Hello, I've been trying to solve the problem with the unit GLext for some
time and I am getting mad. I need to use vertex shaders written in GLSL, but
I am a novice in that field so I may be doing domething wrong. I have glext
in my "uses". I tried just to call glCreateProgramObjectARB but I've got
access violation in my program. So I looked into source of glext and there
are some functions which look like I could use them. So I tried
glext_LoadExtension('GL_version_1_4'). Same problem - access violation. So I
tried glext_ExtensionSupported with some parameters. Access violation. I am
really getting mad, I have no idea what to do. 

I am really opened to any suggestions :-)

Thank you

Jakub Marian
View this message in context: http://www.nabble.com/GLext-in-Free-Pascal-does-not-work--tp15599350p15599350.html
Sent from the Free Pascal - General mailing list archive at Nabble.com.

More information about the fpc-pascal mailing list