[fpc-pascal] FPC only 32 bits?

Francisco Reyes lists at stringsutils.com
Wed Jun 6 02:57:25 CEST 2007

Marco van de Voort writes:

> Then you need to crosscompile (see http://www.stack.nl/~marcov/buildfaq.pdf
> ) to AMD64, and fix the problems in the end.


> It is possible to create a binary for amd64, but that binary doesn't work,
> and I don't know why. FreeBSD keeps complaining it can't execute it.

Free Pascal Compiler version 2.3.1 [2007/06/05] for x86_64
Copyright (c) 1993-2007 by Florian Klaempfl

Is this it?

I cross compiled using:
cd ~/fpc
gmake distclean
# next all on one line
gmake all install CPU_TARGET=x86_64 OS_TARGET=freebsd 
CROSSBINDIR=/vol2/fp-amd/fpc/cross/bin BINUTILSPREFIX=x86_64-freebsd 

How do I tell it where to look for the rtl units?

Tried compiling a simple progrma like:
compiler/ppcrossx64 -Xr rtl/ programs/crtxy.pp

Thr crtxy.pp is a trivial program that uses the crt unit.

Gave me the error:
Fatal: Can't find unit System used by crtxy
Fatal: Compilation aborted

Also tried putting 
{$UNITPATH /data/fpc/rtl}
At the top most line of my program. 

When I installed in i386 I used the FreeBSD port so this is my first install 
from source.. specially cross-compiling.. 

Just trying to see if my cross compile worked.
Trying on my laptop, which is FreeBSD AMD64.
Compiled on my desktop with FreeBSD i386.

More information about the fpc-pascal mailing list