[fpc-pascal] support for FreeBSD4 broken in fpc 2.0.4

Marc Santhoff M.Santhoff at t-online.de
Tue Feb 6 06:58:30 CET 2007

Am Sonntag, den 28.01.2007, 22:55 +0100 schrieb Marco van de Voort:
> > Am Freitag, den 26.01.2007, 22:31 +0100 schrieb Marco van de Voort:
> > 1. reconstructed the original cprt0.as
> Yes. Also note the version numbers in the abitag (currently 504000 meaning
> 5.4).
> > 2. recompiled fpc-2.0.4 release sources
> > 3. added "-Xf" to my .fpc.cfg
> > 4. tried a complete compile of lazarus and a testing program of mine
> Don't. First start to get a simple file working, not directly lazarus. Start
> with 2.0.2 cprt0.as and start modifying that. I think that is easier than
> working backwards from 2.0.4
> > But sadly I were not successful, the only error I get is the same as
> > before, initializing tls fails:
> There is no TLS in 4.x. So you either left in the tls stuff in your cprt0.as
> reconstruction, or you failed to update the preinstalled version (cprt0.o).

Okay, now it worked. I must have been mixing up things in the first
round, because using fpc 2.0.2's cprt0.as and a full "gmake clean all"
and "gmake install INSTALL_PREFIX=..." did actually do the trick
(verified by compiling lazarus). The missing link from the start on was
the -Xf switch and a clean de- and reinstallation.

So I'm happy but there are some small questions left:

What about the other two items


Do they have to be fetched from 2.0.2, too?
What are they good for?

Thanks for your assistance,

More information about the fpc-pascal mailing list