[fpc-pascal] Version 1.9.6[??] on the Mac.

Peter H.M. Brooks peter at new.co.za
Sat Jan 15 17:43:16 CET 2005

Pedro Lopez-Cabanillas wrote:

>You need to use FPC 1.9.4 or later; 1.9.6 should work, as Jonas pointed, 
>because I'm using some features not available in older releases.
Here's a really curious thing!

I've been working to compile smf.pas. I've loaded fpc 1.9.6 on Windows 
XP and, indeed, it compiles perfectly - later I get errors finding Libc, 
but that's understandable as it isn't Unix, besides I really want it wo 
work on the Mac.

So, I've loaded fpc 1.9.6 on my Mac (powerpc, Mac/OS 10.x.x - the 
latest). When I try to compile it, I get the same error about the byte 
array, using Xcode. So I tried it with a command line compile:

ppcppc -Sd smf.pas

I get the same problem! This was very peculiar, so I tried:

ppcppc -iV

So I haven't loaded the wrong compiler by mistake.

It looks very much as if the code for the 1.9.6 compiler on Windows/XP 
and Mac/OS is different - in fact it looks as if the Mac version is an 
earlier release.

How could this have happened? Should I download the compiler and compile 
it from scratch, or is it likely that somebody will fix the problem?

Could I have something else wrong?

Have you actually managed to compile this on a Macintosh running the 
Panther OS?

While on the subject, of compiling the compiler. I have a dual 64-bit 
CPU on my Mac. Would it be possible to compile the compiler to run in 
64bit mode and be multi-threaded - and produce code that is 64bit and 
multi-threaded? I know that Tiger will provide full 64bit operation (at 
least that is promised), but, in theory, the compiler should be able to 
produce 64bit code now. If not, how long before this will be possible? 
Is it difficult to do?

More information about the fpc-pascal mailing list