[fpc-pascal]sockets and mysql problems with fpc on Windows 95

Fernando Lozano fsl at centroin.com.br
Thu Aug 23 03:14:59 CEST 2001


> > I tried some somple sockets and mysql programs on Windows 95 and Windows
> > 98, using fpc-1.0.4. They work great on Linux, but not on Windows.
> >
> > The sockets program gets garbage from the socket, although when run from
> > inside gdbpasw it gets the correct data. The mysql program aborts on
> > error 103 (file not open) at any writeln procedure call after the
> > connection is estabilished. Again, if I run under gdbpasw I can see it
> > gets the correct data from mysql, but this time it aborts also under
> > gdbpasw.
> >
> > Any hint? It's a problem with the OS or should I try a 1.1 shapshopt?
> Try downloading newer packages. This is an error in the Mysql headers which
> has been fixed meanwhile. When 1.0.6 is released this problem will be solved
> for all.

Wasn't the problem on the Windows version of the mysql unit related just
to requiring liibc and libm? Does the problem affect also the sockets
unit? As reported on the same message, but the problems are unrelated...

[]s, Fernando Lozano

More information about the fpc-pascal mailing list