[fpc-pascal]sockets and mysql problems with fpc on Windows 95

Fernando Lozano fsl at centroin.com.br
Wed Aug 22 20:25:00 CEST 2001

Hi there!

I tried some somple sockets and mysql programs on Windows 95 and Windows
98, using fpc-1.0.4. They work great on Linux, but not on Windows.

The sockets program gets garbage from the socket, although when run from
inside gdbpasw it gets the correct data. The mysql program aborts on
error 103 (file not open) at any writeln procedure call after the
connection is estabilished. Again, if I run under gdbpasw I can see it
gets the correct data from mysql, but this time it aborts also under

Any hint? It's a problem with the OS or should I try a 1.1 shapshopt?

The programs are attached so you can test them. leweb1.pas is the
sockets program and testdb.pas is the mysql one.

PS: Any hope to get 1.0.6 fixing these and other problems?

[]s, Fernando Lozano
-------------- next part --------------
A non-text attachment was scrubbed...
Name: leweb1.pas
Type: application/x-unknown-content-type-pas_auto_file
Size: 1535 bytes
Desc: not available
URL: <http://lists.freepascal.org/pipermail/fpc-pascal/attachments/20010822/99a6c0c2/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: testdb.pas
Type: application/x-unknown-content-type-pas_auto_file
Size: 1841 bytes
Desc: not available
URL: <http://lists.freepascal.org/pipermail/fpc-pascal/attachments/20010822/99a6c0c2/attachment-0001.bin>

More information about the fpc-pascal mailing list