[fpc-devel] Just need to double check the size of Integer

Michael Van Canneyt michael at freepascal.org
Thu Nov 24 15:08:11 CET 2022

On Thu, 24 Nov 2022, Marco van de Voort via fpc-devel wrote:

> On 24-11-2022 14:59, Michael Van Canneyt via fpc-devel wrote:
>> SizeInt = SmallInt;
> (IMHO get rid of small and short in general, and simply put int8/16 instead. 
> But that might require compiler work?)


I would also prefer the use of int8/uint8/int16/uint16 etc. as the basic
compiler types, but those will indeed need some compiler work, which is why
I didn't propose it.

If they appear, at that point we can define Small/Short/LongInt simply as aliases.
It would be much more clear.


More information about the fpc-devel mailing list