[fpc-devel] Windows Console App

Ozz Nixon ozznixon at gmail.com
Sun Apr 26 11:05:35 CEST 2020

I will check your suggestions Alexander.

Checked the code, it does if paramcount=0 then show help, then exit from
main begin/end. It does not interact with the keyboard unless instructed to
(its a pascal script engine).

On Sun, Apr 26, 2020 at 3:28 AM Alexander Grotewohl <alex at dcclost.com>

> you're not using the crt unit are you? first because i think it doesn't
> support utf8 and second because i think you can cause this by doing "if
> keypressed.." without then doing readkey before exit.
> --
> Alexander Grotewohl
> https://dcclost.com
> ------------------------------
> *From:* fpc-devel <fpc-devel-bounces at lists.freepascal.org> on behalf of
> Ozz Nixon via fpc-devel <fpc-devel at lists.freepascal.org>
> *Sent:* Saturday, April 25, 2020 8:21:13 PM
> *To:* FPC developers' list <fpc-devel at lists.freepascal.org>
> *Cc:* Ozz Nixon <ozznixon at gmail.com>
> *Subject:* [fpc-devel] Windows Console App
> Anyone ever experience making a console app (cross-platform), but, on
> windows when the app finishes, it appears to have put an uppercase C or D
> in the keyboard buffer, so the Prompt now has C:\>D<cursor>  ???
> Every time I run my app, be it show help screen and end, or actually
> execute - when it finishes I end up with a letter sitting at the prompt. (A
> few months ago, I was having a problem, and it was related to compiling all
> of the methods with cdecl. That build would leave a stray "C" at the start
> of the prompt upon exiting. Now, I ran into a new problem where I needed to
> recompile with -FcUTF8 to track down which units it thought were having a
> UTF-8 mismatch... it was showing the wrong unit until I used the -FcUTF8
> compile option, then it actually showed what file had '<highbit ascii>'
> strings ... so I switched to #<byte_number> and it compiles, but, the
> prompts have "D" at the start of them now.    (hopefully I described that
> understandable).
> Environment: Windows XP 32bit
> C:\FPC\3.0.4\bin\i386-Win32\fpc.exe
> If no one else has experienced/has a solution, I will sit down and bang
> out test cases until I find what combination (units, code, whatever) is
> producing this result.
> Ozz
> _______________________________________________
> fpc-devel maillist  -  fpc-devel at lists.freepascal.org
> https://lists.freepascal.org/cgi-bin/mailman/listinfo/fpc-devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freepascal.org/pipermail/fpc-devel/attachments/20200426/ee91f6b2/attachment-0001.html>

More information about the fpc-devel mailing list