[fpc-devel] Fix CamelCase in unit and method names

Anthony Walter sysrpl at gmail.com
Thu Mar 22 16:53:22 CET 2018

Yes, I agree, both for unit names, but also for methods and arguments. The
exceptions should be for code related that are imports or extensions of
existing APIs, for example:

cairo_create should remain the same
glGenBuffers should remain the same
gtk_window_new should remain the same
dlopen should remain the same

But in the RTL or LCL here are some of many pure pascal functions or
procedures that could have their case changed:

abs should be Abs
arctan should be ArcTan
getdir should be GetDir
intpower should be IntPower
hexstr should be HexStr
strcan should be StrScan

And with RTL or LCL unit names:

keyboard should be Keyboard
math should be Math
strutils should be StrUtils
cthreads should be CThreads

Same applies to function/procedure/method arguments. If they're a pure
pascal original, then arguments should be CamelCase. If they are part of an
API imported, then they should remain the way the original API declares

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freepascal.org/pipermail/fpc-devel/attachments/20180322/7ac7c479/attachment.html>

More information about the fpc-devel mailing list