[fpc-devel] Porting fpc to linux-sparc64

Karoly Balogh (Charlie/SGR) charlie at scenergy.dfmk.hu
Mon May 29 15:20:01 CEST 2017


On Mon, 29 May 2017, John Paul Adrian Glaubitz wrote:

> On Mon, May 29, 2017 at 02:57:51PM +0200, Karoly Balogh (Charlie/SGR) wrote:
> > Indeed, this worked. Also, not sure what Adrian was doing wrong, but I
> > added -32 into sparc/cpugas.pas file as I said, and from then on I started
> > getting 32 bit object files, and after fixing the Makefile, I got a 32bit
> > FP executable, crosscompiled. Maybe something on the buildbox will reveal,
> > why it doesn't work there.
> Nope. Still doesn't work here. Maybe my brain is just messing things
> up in today's heat here in Berlin :O.

I'm also sitting in Berlin, so we're having different delusions from the
heat then... :) BTW, I sent you a pubkey.

It's easy to test how the assembler behaves, using those standalone .as
files. So "sparc64-linux-gnu-as -Av9 -32 prt0.as -o prt0.o" should result
in a 32 bit object. If that doesn't work, nothing will.


More information about the fpc-devel mailing list