[fpc-devel] Closures / anonymous methods

Paul van Helden paul at planetgis.co.za
Wed Oct 26 13:33:01 CEST 2016

On Wed, Oct 26, 2016 at 12:48 PM, Michael Van Canneyt <
michael at freepascal.org> wrote:

> On Wed, 26 Oct 2016, Maciej Izak wrote:
> 2016-10-26 11:56 GMT+02:00 Michael Van Canneyt <michael at freepascal.org>:
>> As long as it's really a separate mode (plus maybe modeswitches for
>>>> selected features, that other modes might profit from) I don't see a
>>>> problem with adding an Oxygene mode.
>>> Indeed. This is the reason modes were invented.
>> This is obvious. I won't touch the holy OBJFPC mode ;). Ever. I am
>> worried about the speed of reviewing patches and integrations. For example:
>> Management operators are key feature for many elements in Oxygene mode.
>> Today I am 28 years old. I think that maybe before my 40th birthday FPC
>> team decide to merging Management Operatos into trunk -,- . If Oxygene
>> patch is next, which relay on MO... 80th birthday?
> Specially when they are as invasive as yours. You are in essence
> converting pascal to a C++ clone with this MO patch. Is it so bad that this
> is discussed thoroughly first ?
+1 for Oxygene mode. An Oxygene mode to me will be like early Christmas and
the next 10 years' Christmases rolled together!

I disagree that modernizing Pascal is making it into a C++ clone. Why not
take the best features of C++ while keeping Pascal readable? (FPC did that
allready with I+=2, not that I'm arguing this is more readable. A better
example would be ** vs. Power() - a no-brainer if you ask me, though I'd
prefer ^ which was in Algol).

Allowing EMB to dictate the future of Pascal is just wrong. Look what
they've done with parallelism compared to Oxygene's clean (Pascal-like)
approach. How is TParallel.For Pascallish? The difference seems to be that
Pascal purists don't want to add keywords, while Oxygene adds many new
keywords (eg. nullable, future, async, for parallel, is not, etc).

And then for some flame-bait: I like declaring variables inside begin..end;
;-) To me it looks perfectly Pascallish if it starts with var.. and it is
necessary anyway for duck typing, nullable types, etc.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freepascal.org/pipermail/fpc-devel/attachments/20161026/798ae923/attachment.html>

More information about the fpc-devel mailing list