[fpc-devel] CriticalSection functions differ from Delphi

Ondrej Pokorny lazarus at kluug.net
Fri Aug 5 23:22:54 CEST 2016

CriticalSection function names differ from Delphi:

Delphi - FPC
InitializeCriticalSection <> InitCriticalSection
EnterCriticalSection "=" EnterCriticalsection
LeaveCriticalSection "=" LeaveCriticalsection
DeleteCriticalSection <> DoneCriticalsection

Is there any reason for it? Is there a will to rename them in order to 
get Delphi-compatibility?

(+ FPC char case isn't consistent.)


More information about the fpc-devel mailing list