[fpc-devel] FPC 3.0.0rc2 and fppkg

Joost van der Sluis joost at cnoc.nl
Mon Oct 26 13:17:40 CET 2015

Op 26-10-15 om 09:19 schreef Anthony Walter:
> I got it working, somewhat.
> It would seem that you have to duplicate the entire FPC lib tree 
> underneath {UserDir}.fppkg/

No, that should not be necessary. Fppkg uses two locations to install 
packages. One is {UserDir}.fppkg (the local version), but the other one 
should be the location where fpc is installed. That way there is no need 
to duplicate. Read the other mail for hints why it can not find your 
global configuration.

> The instructions at the page referenced in my last post are very 
> unclear about that.
> I suppose under normal fpc install this is needed because the lib 
> files are typically only create as root under some folder other than 
> your $HOME (done during install). This copy (assuming everything in 
> fpc/lib is needed) results in an extra 900MB of files duplicated and 
> eating up disk space (I use small SSDs on my laptop),
> However, since I always clone FPC and Lazarus from sources and build 
> somewhere under my $HOME folder (normally $HOME/Development/Base or 
> $HOME/Development/FreePascal), I was able to set LocalRepository 
> and GlobalPrefix in ~/.config/fppkg.cfg to my FPC folder 
> ( $HOME/Development/Base/fpc) and then fppkg worked, sort of.

This should have worked 'out-of-the-box', and it should work with fpc 
3.0.0-rc2, but it could be that you hane to tweak fpc 3.1.1.

> I found that almost all package were already "installed". I take 
> installed to mean the package source were are already included with 
> FPC and compile when I ran "make all" some time ago.
> Of the 6 package not installed, I could only compile half. The rest 
> complained with results similar to the following:
> Target OS: Linux for x86-64
> Compiling custembweb.pp
> PPU Loading 
> /home/gigauser/Development/Base/fpc/lib/fpc/3.1.1/units/x86_64-linux/lnet/lnetssl.ppu
> PPU Source: lnetssl.pp not found
> Recompiling lNetSSL, checksum changed for openssl
> lnetssl.pp(43,57) Fatal: Can't find unit lNetSSL used by lhttp
> Fatal: Compilation aborted

Each compiler-version has it's own repository. I did test all packages 
in the 3.0.0 repository. I'll update the 3.1.1 packages later.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freepascal.org/pipermail/fpc-devel/attachments/20151026/5107f7f8/attachment.html>

More information about the fpc-devel mailing list