[fpc-devel] FPC 3.0.0rc2 and fppkg

Anthony Walter sysrpl at gmail.com
Mon Oct 26 09:19:02 CET 2015

I got it working, somewhat.

It would seem that you have to duplicate the entire FPC lib tree
underneath {UserDir}.fppkg/

The instructions at the page referenced in my last post are very unclear
about that.

I suppose under normal fpc install this is needed because the lib files are
typically only create as root under some folder other than your $HOME (done
during install). This copy (assuming everything in fpc/lib is needed)
results in an extra 900MB of files duplicated and eating up disk space (I
use small SSDs on my laptop),

However, since I always clone FPC and Lazarus from sources and build
somewhere under my $HOME folder (normally $HOME/Development/Base or
$HOME/Development/FreePascal), I was able to set LocalRepository
and GlobalPrefix in ~/.config/fppkg.cfg to my FPC folder
( $HOME/Development/Base/fpc) and then fppkg worked, sort of.

I found that almost all package were already "installed". I take installed
to mean the package source were are already included with FPC and compile
when I ran "make all" some time ago.

Of the 6 package not installed, I could only compile half. The rest
complained with results similar to the following:

Target OS: Linux for x86-64
Compiling custembweb.pp
PPU Loading
PPU Source: lnetssl.pp not found
Recompiling lNetSSL, checksum changed for openssl
lnetssl.pp(43,57) Fatal: Can't find unit lNetSSL used by lhttp
Fatal: Compilation aborted
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freepascal.org/pipermail/fpc-devel/attachments/20151026/ceb6c335/attachment.html>

More information about the fpc-devel mailing list