[fpc-devel] Testing FPC on PPC Mac

Mark Morgan Lloyd markMLl.fpc-devel at telemetry.co.uk
Thu Feb 12 12:17:23 CET 2015

Mark Morgan Lloyd wrote:

>> Afaik that's it, binutils+make+gdb from xcode + the installer.
> Thanks, I'll see where I get to.

Testing 2.7.1 at revision 29398, compiling with

make NOGDB=1 OPT='-V2.6.4 -O- -gl -Xs-' all

which has worked for the other architectures I've tried it on, I get

/bin/mkdir -p powerpc/units/powerpc-darwin
/usr/local/bin/ppcppc -Ur -Xs -O2 -n -Fupowerpc -Fusystems 
-Fipowerpc -FE. -FUpowerpc/units/powerpc-darwin -dRELEASE -V2.6.4 -O- 
-gl -Xs-   -dpowerpc -dGDB -dBROWSERLOG -Fuppcgen -Sew pp.pas
/usr/bin/ld: unknown flag: -macosx_version_min
An error occurred while linking
pp.pas(244,13) Error: Error while linking
pp.pas(244,13) Fatal: There were 1 errors compiling module, stopping
Fatal: Compilation aborted

I presume that ld from Xcode 2.0 is slightly too old, and that that flag 
isn't supported. Is there a way of accommodating this at the command 
line, or is the only way by finding the flag in the build files and 
disabling it?

[Slightly later] It looks as though it's in the compiler itself, so I'd 
presumably have to start off with a cross-build or work back to 2.6.0... 
which is a lot of work for an architecture that I don't really use.

Mark Morgan Lloyd
markMLl .AT. telemetry.co .DOT. uk

[Opinions above are the author's, not those of his employers or colleagues]

More information about the fpc-devel mailing list