[fpc-devel] Trunk does not compile for armv6m since rev. 26346

Michael Ring mail at michael-ring.org
Thu Jan 2 15:18:06 CET 2014

I tried rev. 26354, the problem is not yet fixed, perhaps Jonas is right 
and there's more to do... I both tried armv7m and armv6m, both break:

ring/devel/fpc/rtl/units/arm-embedded -darm -dRELEASE -O- -gw2 
-Fi../objpas/sysutils sysutils.pp
dati.inc(80,34) Fatal: Internal error 2002090902
Fatal: Compilation aborted

this is my commandline for building:

make clean buildbase CROSSINSTALL=1 OS_TARGET=embedded CPU_TARGET=arm 
SUBARCH=$SUBARCH CROSSOPT="-O- -gw2" BINUTILSPREFIX=arm-none-eabi- || exit 1

Am 02.01.14 14:35, schrieb Jonas Maebe:
> On 02 Jan 2014, at 14:11, Nico Erfurth wrote:
>> I've added a new CPU-feature flag CPUARM_HAS_UMULL and also used it for
>> the 64x64=>64bit code.
> I think it would be cleaner to also use it in 
> tarmaddnode.use_generic_mul32to64 (maybe it's also necessary for 
> correctness, since in pass_1 you check is_64bitint(left.resultdef) in 
> tarmaddnode.pass_1 and that will return false if use_generic_mul32to64 
> returned true, which it currently always does).
> Jonas
> _______________________________________________
> fpc-devel maillist  -  fpc-devel at lists.freepascal.org
> http://lists.freepascal.org/mailman/listinfo/fpc-devel

More information about the fpc-devel mailing list