[fpc-devel] Linux x86_64 trunk fails to build

Anthony Walter sysrpl at gmail.com
Fri Apr 26 05:57:02 CEST 2013

For testing purposes I downloaded the Ubuntu 13.04 64bit version (which
came out today) and tried to build the fpc trunk. I encountered the
following problem during "make all":

/home/username/fpc-2.6.2/bin/ppcx64 -Ur -Xs -O2 -n -Fux86_64 -Fusystems
-Fu/home/username/fpc/fpc/rtl/units/x86_64-linux -Fix86_64 -FE.
-FUx86_64/units/x86_64-linux -Cg -dRELEASE    -dx86_64 -dGDB -dBROWSERLOG
-Fux86 -Sew pp.pas
nx64flw.pas(32,37) Error: Identifier not found "tcgraisenode"
nx64flw.pas(32,37) Error: class type expected, but got "<erroneous type>"
nx64flw.pas(33,17) Error: There is no method in an ancestor class to be
overridden: "tx64raisenode.pass_generate_code;"
nx64flw.pas(52,1) Fatal: There were 3 errors compiling module, stopping
Fatal: Compilation aborted

I had this error twice. The first time I tried using Ubuntu's fpc package
(sudo apt-get install fpc) which gave me fpc version 2.6.0.

After that first failure I removed the fpc package and tried using version
2.6.2 (from http://sourceforge.net/projects/freepascal/?source=dlp) to make
the trunk version. I encountered the same error when attempting "make all"
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freepascal.org/pipermail/fpc-devel/attachments/20130425/79dc5520/attachment.html>

More information about the fpc-devel mailing list