[fpc-devel] FPC -Rintel and -alr options

ABorka fpc-devel at aborka.com
Tue Aug 21 07:38:28 CEST 2012

For example

fpc -Rintel -alr -MObjFPC -Scgi -O1 -Twin32 -Pi386 -g -gl -WG -vewnhi -l 
-FuC:\...something... -FuC:\lazarus\lcl\units\i386-win32\win32 
-FuC:\lazarus\packager\units\i386-win32 -FuC:\...something...\ 
-FUC:\...something...\lib\i386-win32\ -oMyProgram-win32.exe -dLCL 
-dLCLwin32 MyProgram.lpr

The "*.s" files are there, but all are in AT&T syntax, not Intel

Tried to put
into the fpc.cfg also, with the same result.

On 8/20/2012 20:26, waldo kitty wrote:
> On 8/20/2012 21:38, ABorka wrote:
>> Is there a way to see the generated ".s" assembly files as Intel
>> syntax instead
>> of the AT&T one?
>> The -Rintel flag does not seem to work, or I am doing something wrong.
>> Tried command line and fpc.cfg both, on win32 and win64, latest SVN .
> what command line, exactly, please?
> _______________________________________________
> fpc-devel maillist  -  fpc-devel at lists.freepascal.org
> http://lists.freepascal.org/mailman/listinfo/fpc-devel

More information about the fpc-devel mailing list