[fpc-devel] New FPC target: JVM

dmitry boyarintsev skalogryz.lists at gmail.com
Sun Aug 21 20:39:29 CEST 2011

On Sun, Aug 21, 2011 at 5:33 PM, Jonas Maebe <jonas.maebe at elis.ugent.be> wrote:
> The problems are
> a) he is adding the '.class' extension when trying to run the program. You have to specify the name of the class to run, not the name of the class file (so leave out the '.class')
> b) he should specify the base path to the FPC rtl classes via the -cp parameter, as explained at http://wiki.freepascal.org/FPC_JVM/Usage#Running_compiled_programs
> I've added a quick start example at http://wiki.freepascal.org/FPC_JVM#Quick_start

I followed the instruction and again it failed to run the application.
However, it's unsaid that location of the ".class" file should also be
listed in "-cp" option. At least it worked fine for me.  I tried it in
Windows, so I'm not sure if it's required for Unix OSes, but it
appears that working directory isn't used by "java" for classpath
Jonas, I'd suspect you have environment variable CLASSPATH setup in
your system or something like that, that doesn't require you specify
the path to .class file.

In the end, it has nothing to do with ppcvmj, but rather than usage of
"java" application :)
I added a small note to Quick Start feel free to delete it anyway.


More information about the fpc-devel mailing list