[fpc-devel] FPC 2.6.x branched, trunk becomes 2.7.1

Marcos Douglas md at delfire.net
Wed Aug 3 20:32:23 CEST 2011

On Wed, Aug 3, 2011 at 3:01 PM, Marcos Douglas <md at delfire.net> wrote:
> On Wed, Aug 3, 2011 at 2:47 PM, Jonas Maebe <jonas.maebe at elis.ugent.be> wrote:
>> On 03 Aug 2011, at 19:42, Marcos Douglas wrote:
>>> I use ppc386 2.4.3 to compile and tools in /branches/fixes_2_4/install/binw32
>>> With configuration I can compile /branches/fixes_2_4 and /trunk
>>> Where I got data2inc.exe
>> As Marco said, it is part of any default FPC installation that you download from our website. Compiling with just a compiler binary in your may work, but that is not a supported configuration for general use (a.o. reasons, because of the problem you have right now). Please always start from a *full* installation of the latest official release before reporting build problems. In 99.9% of the cases it solves all problems.
> Sorry Jonas, but I always compile two versions (fixes_2_4 and trunk)
> using this script:
> http://wiki.freepascal.org/Installing_Lazarus#Compiling.2Finstalling_FPC_and_Lazarus_from_Sources_of_SVN_.28Win32.29
> Always worked and some people used this script with success too.
> How I compiled before without having to compile the file data2inc?
>>> and why I can compile trunk but not the 2.6.0 release?
>> There is no 2.6.0 release yet. And the reason for your compilation error is that the time stamps on some include files in your fixes_2_6 branch are older than the files they are generated from. This can happen with a fresh svn checkout depending on the order in which files are downloaded and how much time passes in the mean time.
> The sources are fresh.
> So, I will 'clean up' the sources and to try again...

Same error...

I'm getting a fresh /fixes_2_4 to try to compile with the same script
and tools in /branches
If it works, I will do the same with /trunk...
If it works... well, IMHO, something is wrong in /branches/fixes_2_6

Marcos Douglas

More information about the fpc-devel mailing list