[fpc-devel] Fwd: GDB 7.0.90 available for testing

Marco van de Voort marcov at stack.nl
Sat Feb 20 16:35:13 CET 2010

In our previous episode, Marco van de Voort said:
> I tried to build the IDE with libgdb, and it seems some deprecated symbols
> were removed:
> C:\repo\fpc\packages\gdbint\units\i386-win32\gdbint.o: In function
> `GDBINT_finalize_implicit':
> C:/repo/fpc/packages/gdbint/src/gdbint.pp:(.text.n_gdbint_tgdbinterface_$__gdb__init+0x20):
> undefined reference to `deprecated_create_breakpoint_hook'
> C:/repo/fpc/packages/gdbint/src/gdbint.pp:(.text.n_gdbint_tgdbinterface_$__gdb_done+0x20):
> undefined reference to `deprecated_create_breakpoint_hook'
> C:/repo/fpc/packages/gdbint/src/gdbint.pp:(.text.n_gdbint_initlibgdb+0x96):
> undefined reference to `error_init'

After searching a bit, I decided it should work as is. (with the workaround
that one links the IDE externally and some minor linklib related patches in

I retried, and zapped the installed snapshot's gdbint to be sure, and now it
worked.  Funky, but at least if it was my fault, it is a FPC problem, not
GDB.  The strange part is that in my snapshot build logs (and gdbver.inc ) I
could see that the correct gdb version was chosen (v7), yet somehow for
linking other .o's  were used!?!

Anyway, all's right now,

I uploaded the result to ftp://ftp.freepascal.org/pub/fpc/contrib/libgdb/
in case people want to test.

More information about the fpc-devel mailing list