[fpc-devel] Proposal: Enhanced replacement for assignment operators

Marc Weustink marc at dommelstein.net
Sat Aug 7 11:54:55 CEST 2010

Alexander Klenin wrote:

> Code bloat/duplication is much more serious.
> It is usually not just SomeReallyLongVariableNameY, but something like:
> SomeFunctionReturningObject(param1, param2).PointArrayField[i] +=
> FunctionReturningPointOffset(param);
> Try rewriting that without "+=".

Again, we are back at lazy typing. Somehow typing the realy long 
valiable name is not a problem, but declaring an extra variable is.
(and with lazarus even that isn't needed)

What is wrong with :

MyObj := SomeFunctionReturningObject(param1, param2);
MyObj.PointArrayField[i] := MyObj.PointArrayField[i] +

Why are you still using pascal ?


More information about the fpc-devel mailing list