[fpc-devel] Proposal: Enhanced replacement for assignment operators

Martin fpc at mfriebe.de
Fri Aug 6 16:50:11 CEST 2010

  On 06/08/2010 15:45, Alexander Klenin wrote:
> On Sat, Aug 7, 2010 at 01:37, Martin<fpc at mfriebe.de>  wrote:
>>   On 06/08/2010 15:23, Alexander Klenin wrote:
>>> On Sat, Aug 7, 2010 at 01:12, Martin<fpc at mfriebe.de>    wrote:
>>> What it the difference? I agree that "%" is slightly better notation than
>>> "mod",
>>> but that is totally insignificant, and since we are stuck with "mod",
>>> I see no reason to change it.
>> Because mixing/combining a word (identifier) with a symbol, well for me: it
>> hurts my eyes.
> As I said, I agree, "a mod b" looks worse than "a % b",
> but that was Wirth's decision, and the difference is so small
> I do not think it is really an issue.
I don't have a problem with "a mod b" => only with "a mod= b"

mod is a keyword, it therefore follows the rule (as identifier)  that it 
consists of certain chars only (a-z, underscore, digits, but not leading)

:= += are symbols => they do not consist of said chars

mod= is what exactly?

More information about the fpc-devel mailing list