[fpc-devel] Re: Testing for..in feature

Paul Ishenin ip at kmiac.ru
Thu Nov 5 05:48:54 CET 2009

Alexander Klenin wrote:
> So, I vote for converting "for i in Enum do" into
> while ... do
>   ...
>   i := Succ(i);
> end;

No need to complicate the code generation for all enums. This can be 
done only for the enums with jumps.

Best regards,
Paul Ishenin.

More information about the fpc-devel mailing list