[fpc-devel] Ref documentation doesn't mention "deprecated" keyword

Paul Ishenin ip at kmiac.ru
Mon Jun 1 10:30:23 CEST 2009

Graeme Geldenhuys wrote:
>> type
>>  TMyClass = class(TObject)
>>  end deprecated;
> I tried, but get a compiler error. :-(  It would be very handy though.
> Especially in tiOPF (and probably FPC and LCL as well), we have old
> classes that have since been renamed or refactored that they are not
> needed anymore. I would like to encourage developers to use the newer
> classes instead.

Have you tried as I wrote?

>> As I know you can deprecate any symbol and even unit.
> How do you mark a unit as deprecated?
> In the user.pdf I have seen many references to units being deprecated
> (eg: graph, oldlinux, etc), but I have only seen that being mentioned
> in the documentation. There doesn't seem to be any compiler reference
> or deprecated keyword marking that unit as deprecated. Or I clearly
> missed something. ;-)

Seems for unit this is not availble if fpc. Delphi allow use of 
deprecated and platform marks for units too.

Best regards,
Paul Ishenin.

More information about the fpc-devel mailing list