[fpc-devel] Rebuild Lazarus fails for some reason

Mattias Gaertner nc-gaertnma at netcologne.de
Thu Feb 19 11:50:40 CET 2009

On Thu, 19 Feb 2009 00:19:38 -0800
ABorka <fpc-devel at aborka.com> wrote:

> Hi Michael,
> Yes it was compiled when "make all" was called the first time,
> because c:\lazarus\ideintf\units\i386-win32\ contains
> componenttreeview.ppu and componenttreeview.o and both has the same
> date/time as all the other units there (obviously, because all of
> them were created with the "make all" command at once in step 5).
> That is why it is very strange why this is happening.
> It is a totally clean svn checkout and compilation, and without doing 
> anything within Lazarus, Im just trying to do a Tools->Rebuild
> Lazarus from menu after Lazarus is first started. Of course, I got
> the error originally when tried to add a package so I tried to track
> back what the problem is.
> But even with a clean FPC/Lazarus SVN checkout and build this problem
> is there.
> I have no idea why it wants to recompile this unit, when nothing 
> changed, no packages added or removed, its just a simple rebuild
> Lazarus from the Tools menu after a clean install.

Have you checked that the IDE uses the right lazarus directory in the
Environment Options?


More information about the fpc-devel mailing list