[fpc-devel] a few installation issues (trunc on freebsd)

Martin Friebe fpc at mfriebe.de
Sun Nov 2 20:31:46 CET 2008

I have a few question, regarding my attempts to install fpc from trunc 
(I read the build faq, yet I have not succeeded...)

On a freebsd (7.0) box, I have downloaded and installed the pre-compiled 
fpc 2.2.2 ( to use as my initial compiler.)

I have created my workind dir /data/fpc_trunc/svn and done my checkout 
(Revision: 12021)
  cd /data/fpc_trunc/snv
  svn co http://svn.freepascal.org/svn/fpc/trunk .

then according to the build-faq, I have done
  cd compiler
  gmake cycle

* First problem: I found if I simply go to the parent (svn) directory, 
and do a "gmake all PP=/data/fpc_trunc/svn/compiler/ppc386" there, it 
will do some clean out, and stop because halfway through it will have 
deleted this compiler.

So instead (which is not mentioned in the buildfaq?), I have installed 
the compiler and rtl at this stage:
   gmake install  INSTALL_PREFIX=/data/fpc_trunc/inst/
   cd ../rtl
   gmake install  INSTALL_PREFIX=/data/fpc_trunc/inst/

Note: I am installing to a separate dir, as I want to use this 
installation in parallel to other installations.

* Second Problem: when using fpc (instead of ppc), it will always find 
the ppc386 in the default installation. The only way I can change this 
is "fpc -Xp/path/to/my/ppc386". (Which I found no documentation for. I 
got that from looking through the source) However, if I want to use fpc 
from lazarus, I may not be able to pass that (convenient) on the command 
 Is there any INI file? (fpc.cfg did not help here, at least not the 
fpc.cfg in the same path as fpc exe).
 Or is it save to substitute fpc, with ppc386 everywhere it is called?

any way I then go and create my fpc.cfg:
  cd ../../inst
  ./bin/fpcmkcfg -d basepath=/data/fpc_trunc/inst/lib/fpc/2.2.2 > 

* 3rd problem, it uses the same prefix for the units (-Fu) and the bin 
(-FD), so the above creates correct -Fu config, but I must change the 
-FD conf. Any solution to this ?
-Fu will be correct:
but -FD will *NOT* be (which I think it should?, or am I wrong?)

now I go back to the top svn checkout and to
   gmake all PP=/data/fpc_trunc/inst/lib/fpc/2.2.2/ppc386 

* 4th Problem the compilation aborted (Sorry I don't remember where) 
because it tried to access the x11 package
=> I did solve that by going int packages/x11, did the make there, and 
did install it (with the install prefix)

* 5th problem packages/graph stops, because it tries to use x86. (This 
exists in the sources rtl/unix/x86.pp) Somehow all the above has not 
installed this (not on my FreeBSD), the package is missing int he 
inst/lib.... directory

And last not least, having checked out trunc (or being under the 
impression to have done so), why has the "make install" in the rtl 
installed something with 2.2.2 in the path? (If I run the ppc386 that 
was installed it will say 2.3.1.
Maybe this last bit will solve some of the other questions...

Any help is greatly appreciated. Many thanks.

More information about the fpc-devel mailing list