[fpc-devel] The status of fpmake ?

Peter Vreman peter at freepascal.org
Wed May 21 16:51:29 CEST 2008

> Peter Vreman wrote:
>>> graemeg at graemeg:dialer$ fppkg build
>>> The FPC Package tool encountered the following error:
>>> Could not find package "rtl"
>> run 'fppkg build --debug' to get more information where it is looking for files.
> I tried to do the same now that I have fpmake.pas compiled. So I ran it
> with the '-l' parameter to list what it's trying to do. Still no luck. I
> think fpmake is stuck in 'stupid_mode = True' state. ;)
> graemeg at graemeg:dialer$ ./fpmake compile -l
> The installer encountered the following error:
> Could not find unit directory for dependency package "rtl"

You need to use --verbose or --debug to show what it is doing. The list mode is only for the
actual compile commands. This is all startup.

If you don't have fpc installed in the default locations /usr/[local/]lib/fpc/<version> you need
to set FPCDIR. There is no other way to detect the location.

The /etc/fpc.cfg and ~/.fpc.cfg are for the standalone compiler only and will not be used for
package building. fpmake and fppkg have their own configuration files where optimizer/debug
options will be passed to the compiler.

More information about the fpc-devel mailing list