[fpc-devel] how to compile RTL for ARM-Linux since r8006

Bernd Mueller mueller.b at gmx.net
Tue Jul 10 13:43:54 CEST 2007

Yury Sidorov wrote:
> From: "Bernd Mueller" <mueller.b at gmx.net>
>> Hello,
>> can anyone please tell me, how to compile the RTL for ARM-Linux since 
>> revision 8006?
>> I tried to verify the bug fix 8967 (thank you Yury Sidorov) on my 
>> system, but I am not able to compile the RTL anymore.
>> Adding the -Sg switch seems to be required to compile softfpu, but I 
>> get now:
>> PPU Loading ..\..\rtl\units\arm-linux\dos.ppu
>> Trying to use a unit which was compiled with a different FPU mode
>> objects.pp(734,9) Fatal: Can't find unit dos used by Objects
>> Fatal: Compilation aborted
>> I would like to compile with softfloat disabled.
>> So far, I used following make call:
>> make CPU_TAGET=arm OS_TARGET=linux PP=ppcrossarm OPT="-Tlinux -CX -Sg"
> Try to force hardware FPU mode by using -CfFPA switch.

no, it does not help. I get exactly the same error. Perhaps something 
changed in the build process for the cross compiler? I still use FPC 
2.0.4 as starting compiler to build the cross compiler.

I am building the cross compiler with following make call:
make clean
make PPC_TARGET=arm

Regards, Bernd.

More information about the fpc-devel mailing list