[fpc-devel] FPC won't bootstrap anymore on Mac OS X 10.3

Giulio Bernardi ugilio at hotmail.com
Mon Dec 31 15:27:06 CET 2007

I tried to cycle the compiler on my ancient PowerMacintosh G3 and both 2.2.1 and 2.3.1 fail.
The reason is that the assembler supplied with Xcode 1.5 (the last supported version for 10.3.9) doesn't like the output generated by fpc.
I think that 2.2.0 is not affected since, when cycling, this happens:
fpc 2.2.0 compiles the new rtl (no errors)
fpc 2.2.0 compiles ppc1 (no errors)
ppc1 compiles the rtl, and here apple's as complains: in a couple of places in sysutils.s as says: "Complex expression. Absolute segment assumed".
Since it is a warning I made fpc call as with -W option: compilation continues but then the generated compiler is buggy and crashes.

To "solve" the problem I did a crude hack: I downloaded the apple cctools given with mac os x 10.4.10, I ran make, at some point it fails but the assembler has been built: if I replace my old /usr/libexec/gcc/darwin/ppc/as (cctools-525.obj~1) with the new one (cctools-622.5.1) everything goes fine.

Express yourself instantly with MSN Messenger! Download today it's FREE!

More information about the fpc-devel mailing list