[fpc-devel] Definition of the time-fration in a TDateTime before 30/12/1899

Graeme Geldenhuys graemeg.lists at gmail.com
Mon May 22 23:06:27 CEST 2006


On 5/22/06, Vincent Snijders <vsnijders at quicknet.nl> wrote:
>  From Greame I would like to know how he proposes to update the
> TestSuite, if a new tests it added.

I am busy looking at the /tests directory now, to understand how tests
get grouped. This should give me a clearer idea of what is possible.
It took us a while to get a decent test structure for our code as
well.

I agree that certain tests will have to stay in the format they are in
now.  Things that shouldn't compile, etc... All other tests could be
group in test suites. RTL suite, FCL suite, etc..
Maybe Dean Zobec has some ideas on this too.  Dean?

I like the idea you guys have of using the Bug Report Number as the
test name.  This could be done with fpcUnit as well and should make
tracking of what tests have been converted to fpcUnit quite easy.
eg: Lets say we have a bug #1234 in the RTL.  Edit the RTL suite, by
adding a new method to the test class and the same naming convention
could be used. No extra objects / classes need to be created, just a
new method needs to be added.  Even the person reporting the bug could
write a simple fpcUnit test and submit that to Mantis, which can then
be copied into the correct suite. I submitted a couple of simple
fpcUnit test cases to show a bug, until I found out the FPCCore team
doesn't use the fpcUnit testing framework.  At that stage, I thought
using fpcUnit was the logical choice as it shipped with FPC.

---------  simple example  -----------------
  TRTLTestSuite= class(TTestCase)
  published
    [...]
    procedure Bug1234;
  end;

implementation

procedure TRTLTestSuite.Bug1234;
begin
  Fail('Write your own test');
end;
------------------------------------------------------


Having had a look at a few random tests, they are really short and to
the point, so shouldn't take much time to convert to fpcUnit.


Graeme.


-- 
There's no place like 127.0.0.1


More information about the fpc-devel mailing list