[fpc-devel] Bug: compilation loop in 2.0.2 when using -So

Konstantin Münning konstantin at muenning.com
Thu Aug 17 21:40:38 CEST 2006

Jonas Maebe wrote:
> On 17 aug 2006, at 17:49, Konstantin Münning wrote:
>> I tried again to use 2.0.x compiler (am still using mostly 1.0.10) and
>> encountered a bug which seems to be unknown (according to bugtracker and
>> mailing list) yet.
>> When compiling a unit which uses some RTL unit (I tried only a few) in
>> its IMPLEMENTATION section with -So, the unit is compiled over and over
>> again.
> This is a known bug and it has been fixed.

I'm just testing 2.0.4-rc3 and yes, it's fixed there :-).

There are some other inconsistencies to previous versions of FPC and
Borland Pascal like assembler syntax and pointer addition
(inc(Pointer,LongInt) does not work anymore).

If someone is interested I can post details. It seems possible to work
around them.

Last thing - size. Program tested results with 1.0.10 in 354KB and with
2.0.4-rc3 in 515KB. Both with default optimization options and no debug
info. Tried -Og but result was almost the same. Is this the final state
or are improvements to be expected?


More information about the fpc-devel mailing list