[fpc-devel] bug in fpc 2.0.4 rc 2 (go32v2)?

Daniël Mantione daniel.mantione at freepascal.org
Sat Aug 12 13:58:07 CEST 2006

Op Fri, 11 Aug 2006, schreef kruwi:

> Hello there,
> I think I have to report a bug.
> I have recently downloaded fpc 2.0.4 rc2 for dos (go32v2). I have
> downloaded the full zip package, including sources and docs. 
> After installing the compiler, I tried out to compile and run some
> programs. Everytime I tried to run a program using the graph unit, an
> error occurred: The program would compile, but runnning the project
> always resulted in "run time error 216". 
> All the other programs (those without the graph unit) would run
> flawlessly.
> I never encountered this problem with fpc 2.0.2. All programs, including
> these using the graph unit, work perfectly with fpc 2.0.2 go32v2.
> My system: PII 233, 256 MB RAM, Windows ME.
> Windows ME never showed up any problems regarding the go32v2 version
> with fpc 2.0.2.
> P.S. : I am not yet subscribed to any mailing list.

The problem is that none of the Free Pascal developers uses Dos in any 
serious way, so nobody tests things like the graph unit anymore :(

However, if it works with 2.0.2 it might be a small issue.

Can you load one of these programs in gdb and show us a stack backtrace?


More information about the fpc-devel mailing list