[fpc-devel] OpenGL and glut bugs in Freepascal 2.1.1 running with Mac Os X Tiger ?

Nexus nexus at gmx.net
Sun Oct 30 15:34:55 CET 2005

I have problems with Freepascal 2.1.1 using Mac OS X 10.4.2 Tiger
when running Freepascal Applications which use OpenGL and glut. The sources
are compiled without any warnings but when i run them on the shell they
crash instantly with an unhandled exeception EInvalidOp: Invalid
floating point operation and some memory adresses shown on the screen. The
strange thing about this is when i start the programs after i ran an
application using glut written in C or C++, i can start my freepascal
programs and they run without any error. They then just crash, when they are
running in window mode and i click on the services menuitem in the program
menu (they crash with the same exception EInvalidOP: Invalid floating point
operation, but some times even this works). After quitting the freepascal
open gl program my terminal (shell) is not working correctly anymore (happens only
when running OpenGL applications with glut), keystrokes are not seen 
anymore and CRLF doesn't work any longer. Intrestingly this also happens with 
Linux Version of the compiler (PPC). The same sources compiled with the 
windows version under Windows XP are working without any errors or problems. The
sources where running on my ibook g4 with Mac OS X 10.3 Panther and
Freepascal without any problems, so i can't tell whether it is 
Tiger or the new beta version of the free pascal compiler or some faults on my
system which cause the problems.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freepascal.org/pipermail/fpc-devel/attachments/20051030/ba9c20d3/attachment.html>

More information about the fpc-devel mailing list