[fpc-devel] Compiling error: Invalid Floating point operation

Vincent Snijders vsnijders at quicknet.nl
Thu Mar 10 11:54:03 CET 2005

SteveG wrote:
> Happens on XPPro SP2 Pentium 4 3G as well
> Florian Klaempfl wrote:
>> Vincent Snijders wrote:
>>> uberto at gama-soft.com wrote:
>>>> Compiling current cvs version  on Windows XP (cpu Athlon XP 1800)
>>>> give me
>>>> Invalid Floating point operation
>>>> in /rtl/objpas/sysutils/sysstrh.inc 49:
>>>> I fixed it decreasing MaxCurrency by 1.0 and increasing MinCurrency 
>>>> by the same quantity.
>>>> I didn't investigate it further. But I'm wondering why I'm the only 
>>>> one with this problem.
>>>> sysstrh.inc is version 1.15 last change by peter at 2005/2/14 17:13:31
>>> You are not the only one, it happens to me too, using windows xp sp2 
>>> on a Pentium4 2.6 Ghz, but not using windows 2k on a Pentium4 1.5Ghz.
>>> Also Florian could not reproduce this problem, but somebody else on 
>>> the Lazarus list reported this too.
>> I tried with Windows XP now (AMD64 though), no success, i.e. it works

The call to GetSystemMetrics changes the FPU control word from $1372 to $1272, 
i.e. the Rounding precision is changed from extended to double.

In the attached patch I set it back to the original value. Now I can build a new 
compiler again. :-)

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: diff_fpc.txt
URL: <http://lists.freepascal.org/pipermail/fpc-devel/attachments/20050310/581ff0db/attachment.txt>

More information about the fpc-devel mailing list