[fpc-devel] Compiling error: Invalid Floating point operation

Vincent Snijders vsnijders at quicknet.nl
Sat Mar 5 22:00:47 CET 2005

Florian Klaempfl wrote:
> Vincent Snijders wrote:
>> uberto at gama-soft.com wrote:
>>> Compiling current cvs version  on Windows XP (cpu Athlon XP 1800)
>>> give me
>>> Invalid Floating point operation
>>> in /rtl/objpas/sysutils/sysstrh.inc 49:
>>> I fixed it decreasing MaxCurrency by 1.0 and increasing MinCurrency 
>>> by the same quantity.
>>> I didn't investigate it further. But I'm wondering why I'm the only 
>>> one with this problem.
>>> sysstrh.inc is version 1.15 last change by peter at 2005/2/14 17:13:31
>> You are not the only one, it happens to me too, using windows xp sp2 
>> on a Pentium4 2.6 Ghz, but not using windows 2k on a Pentium4 1.5Ghz.
>> Also Florian could not reproduce this problem, but somebody else on 
>> the Lazarus list reported this too.
> I tried with Windows XP now (AMD64 though), no success, i.e. it works

Can you run this program:
program extconst;

{$mode objfpc}{$H+}

   value: extended;

   value := -922337203685477.5807;

Output with fpc 1.9.8:

Output with ppc1 from 1.9.9 (cvs)

the last value doesn't fit a int64, I think.


More information about the fpc-devel mailing list