[fpc-devel] arm-wince step1

Yury Sidorov jura at ce.blagovest.com
Tue Aug 9 08:17:33 CEST 2005


Writeln to console does not work currently. Writeln to file works (at least 
it worked for me).

Yury Sidorov.

----- Original Message ----- 
From: "Oro06" <orinaudo at gmail.com>
To: <fpc-devel at lists.freepascal.org>
Sent: Monday, August 08, 2005 5:39 PM
Subject: [fpc-devel] arm-wince step1


the good new is the following prog RUN on arm-wince-pda :

var T: text;

-> create the empty file as expected, with no error :)

the bad news is with writeln, every time i try to use it to write in the
file or even
in the std output (console) a simple 'hello world' same error at same place.
tried with inline const, string variable and widestring varaible , here
latest dump
with widestring variable :

   1109c:       e1a01004        mov     r1, r4
   110a0:       e3a00000        mov     r0, #0  ; 0x0
   110a4:       eb007733        bl      2ed78 <FPC_WRITE_TEXT_WIDESTR>
   110a8:       eb0052d0        bl      25bf0 <FPC_IOCHECK>
   110ac:       e1a00004        mov     r0, r4
         <- here (according to objdump) runtime error 103 (103 mean '
The semaphore cannot be set again' )
   110b0:       eb00751b        bl      2e524 <FPC_WRITELN_END>
   110b4:       eb0052cd        bl      25bf0 <FPC_IOCHECK>

Any suggestion ?
i'll have a look insinde FPC_WRITE_TEXT_WIDESTR


fpc-devel maillist  -  fpc-devel at lists.freepascal.org

More information about the fpc-devel mailing list