[fpc-devel]FPC CVS breaks Lazarus build within IDE

Mattias Gaertner nc-gaertnma at netcologne.de
Fri Aug 13 10:11:44 CEST 2004

On Fri, 13 Aug 2004 02:09:16 -0500  Tony Maro <tony at maro.net> wrote:

> I just updated my FPC cvs today.
> My last update was 3 or 4 days ago.
> I haven't updated Lazarus in a week or so.
> The latest FPC update breaks building Lazarus from inside the IDE.  For 
> those familiar, if you try to install a package, Lazarus will optionally 
> rebuild itself.  Now it will either freeze or crash when you try to do
> this.

I spotted some things, that maybe related and may help someone to fix the
If you change something in one of the interfaces of the low level LCL units
like graphics.pp, the current fpc 1.9.5 then gives an internal error 
lcl/graphics.pp(378,1) Fatal: Internal error 200306067
or hangs up (consuming mem till dead), preferable in intfgraphics.pas or
Rebuilding the LCL clean compiles normally, so apparently fpc does not like
some of its ppu files.
I was not able to reproduce this in a smaller example.

> I tried to get a crash, but lately only got the freeze.  Here's the last 
> console out from Lazarus when it stops responding:
> TPascalParserTool.BuildTree B OnlyIntf=False  project1.lpr
> TMainIDE.DoNewEditorFile end unit1.pas
> TMainIDE.DoNewProject end
> [TExternalToolList.Run] /usr/bin/make ide OPT="-Cn"
> Xlib: sequence lost (0x10200 > 0x5c9a) in reply type 0x10!
> Xlib: sequence lost (0x10000 > 0x5c9a) in reply type 0x10!
> I know this isn't a Lazarus list, but like I said, I haven't changed 
> Lazarus code that worked on the CVS from a few days ago, so I assume 
> it's an FPC issue.
> Building from the console with make works fine.  There was some recent 
> discussion about this regarding Win32 building, but this is in Linux 
> that I'm experiencing it.


More information about the fpc-devel mailing list