[fpc-devel]FPC CVS breaks Lazarus build within IDE

Tony Maro tony at maro.net
Fri Aug 13 09:09:16 CEST 2004

I just updated my FPC cvs today.
My last update was 3 or 4 days ago.
I haven't updated Lazarus in a week or so.

The latest FPC update breaks building Lazarus from inside the IDE.  For 
those familiar, if you try to install a package, Lazarus will optionally 
rebuild itself.  Now it will either freeze or crash when you try to do this.

I tried to get a crash, but lately only got the freeze.  Here's the last 
console out from Lazarus when it stops responding:

TPascalParserTool.BuildTree B OnlyIntf=False  project1.lpr
TMainIDE.DoNewEditorFile end unit1.pas
TMainIDE.DoNewProject end
[TExternalToolList.Run] /usr/bin/make ide OPT="-Cn"
Xlib: sequence lost (0x10200 > 0x5c9a) in reply type 0x10!
Xlib: sequence lost (0x10000 > 0x5c9a) in reply type 0x10!
I know this isn't a Lazarus list, but like I said, I haven't changed 
Lazarus code that worked on the CVS from a few days ago, so I assume 
it's an FPC issue.

Building from the console with make works fine.  There was some recent 
discussion about this regarding Win32 building, but this is in Linux 
that I'm experiencing it.


More information about the fpc-devel mailing list