[fpc-devel]CVS compilation problems.

Balogh, Karoly (Charlie/iNQ) charlie at scenergy.dfmk.hu
Tue Jul 15 18:18:24 CEST 2003


I tried to fix the OS/2 main branch snapshot problems last week, 
but with no success. The compilation process stops at the RTL, at 
sysutils.pp AFAIR, by saying there are some declarations not 
compatible with their forward declarations... Anyway, i looked 
through the problem sources, and found no sign of any forward 
declaration for the problematic procedures... I tried to switch 
back to older 1.1, then to 1.0.x, but with no success. Anyway i 
had not much time to play with, so it remained a mystery to me. 

Is it working for others? If not, anyone can take a look at it 


The Linux PPC RTL compilation is broken too, while compiling 
system.pp i get:
/usr/bin/ppcppc -Ur -Xs -n -Fi../inc -Fi../powerpc -Fi../unix -Fe. 
 -dpowerpc -dRELEASE -Us -Sg system.pp
system.pp(35,2) Fatal: Can't open include file "sysunixh.inc"

I'm using the PPC version Jonas gave me as base (dated 2003/06/02).

The interresting part from fpcdebug.txt (used make rtl OPT=-V) 

00020000:interpreting option "-Fi../powerpc"
00000020:Path "/powerpc/" not found

... and so with all other -Fi parameters (unix, inc).

I just tried a recent snapshot on a Linux/x86 box, and there is no
such problem. 

Charlie/iNQ      (SceneCON - http://scenecon.intro.hu)
.:%[ Cybernetic Hydraulic Android Responsible for ]%:. 
.:%[    Logical Infiltration and Exploration      ]%:.
.:%[         Member of TeamOS/2 Hungary           ]%:.
.:%[     Member of Hungarian Amiga User Group     ]%:.

More information about the fpc-devel mailing list