[fpc-devel]Compiling problems

Marco van de Voort marcov at stack.nl
Mon Dec 3 09:15:03 CET 2001

> Has anybody succeeded to compile compiler in win32 environment? I have tried
> it with both 1.0.5 and 1.1 versions many times with out luck. If I install
> everything and go compiler source directory and type "make cycle" it usually
> stops with some include missing. If I add rtl+other sources to compiler
> search path it stop in one include with error code 216 which is protection
> fault.
> If somebody has compiled compiler in win32 environment, could you tell me
> how to do it? 
> Or maybe I shoud RTFM? :)

I ran it last night, and it ran fine. 

There are several possibilities:

- Your start compilers are out of date. The best thing to start with is
   a recent (till about 1.5 month old is fine) 1.0.5 snapshot compiler.

- Your run a NT-based system: check RTFF (the FAQ that is). You need newer GNU
   utils, and adjust your path to be uppercase. Go to the site, select more 
   information and then FAQ

More information about the fpc-devel mailing list