[fpc-devel] New feature discussion: for-in loop

Paul Ishenin ip at kmiac.ru
Thu Oct 22 02:40:21 CEST 2009


Michael Van Canneyt wrote:

> Hm.  I like this direction of thinking, yes...

Hm. I like that after 100 mails of 'yes, I like them', 'no, I don't like 
them' we finnaly moved to the initial idea of the tread - design and 
implementation discussion :)

> What about
> 
>   function StepNext: Boolean; iterator 'movenext';
>   property TheCurrentValue: Integer; iterator 'current';

string are bad.

> or better yet, because it is more strict:
> 
>   function StepNext: Boolean; iterator nextvalue;
>   property TheCurrentValue: Integer; iterator currentvalue;

I like this one. Only not 'iterator nextvalue' and 'iterator 
currentvalue' but 'iterator movenext' and 'iterator current' :)

Or 'enumerator' instead of 'iterator' to be compatible with delphi 
terminology ;)

Best regards,
Paul Ishenin.





More information about the fpc-devel mailing list