<div dir="ltr">I'd be all for just eliminating the "class",  "record", and "type" helper and adding support for just using "helper" in all modes.<div><br></div><div>type</div><div>  TPointHelper = helper for TPoint</div><div>  end;</div><div><br></div><div><div>  TCanvasHelper = helper for TCanvas</div><div>  end;</div></div><div><br></div><div><div>  TDoubleHelper = helper for Double</div><div>  end;</div></div><div><br></div><div>  TInterfaceHelper = helper for IInterface</div><div>  end;</div><div><br></div><div>I know this would make code written this way incompatible with Delphi, but I think pretending the helper type serves no actual purpose. The only thing it does is it makes it harder for developers to remember which names to use in which cases. The compiler should be able to figure it out.</div></div>