<html>
<head>
<meta content="text/html; charset=ISO-8859-1"
http-equiv="Content-Type">
</head>
<body bgcolor="#FFFFFF" text="#000000">
<div class="gmail_extra"><br>
</div>
<div class="gmail_extra">>Enough digression - if considered
carefully a comment about the purpose of an object belongs in the
object definition itself.<br>
<br>
I use Pasdoc for that<br>
<br>
</div>
<div class="moz-cite-prefix">On 07/12/2013 08:07 AM, vfclists .
wrote:<br>
</div>
<blockquote
cite="mid:CAE3mkNAb2Q4a_QYBfL2LOe0RqN3sKMYJqcP7ED7pafRXyKDELA@mail.gmail.com"
type="cite">
<meta http-equiv="Context-Type" content="text/html;
charset=ISO-8859-1">
<div dir="ltr"><br>
<div class="gmail_extra"><br>
<br>
<div class="gmail_quote">On 11 July 2013 23:07, Benito van der
Zander <span dir="ltr"><<a moz-do-not-send="true"
href="mailto:benito@benibela.de" target="_blank">benito@benibela.de</a>></span>
wrote:<br>
<blockquote class="gmail_quote">
<div> Annotations like in Java would be nice...
<div>
<div class="h5"><br>
<br>
<div>On 07/11/2013 10:22 PM, vfclists . wrote:<br>
</div>
</div>
</div>
<blockquote type="cite">
<div>
<div class="h5">
<div dir="ltr">
<div>
<div>
<div>Should TObject or TComponent have a
Comment property?<br>
<br>
</div>
I think they should. One for the design
itself and one for describing the usage at
design or runtime.<br>
<br>
</div>
Smalltalk has it.<br>
<br>
</div>
Consider it a version of the Hint property but
for the developer<br>
<div>
<div>
<div><br>
-- <br>
Frank Church<br>
<br>
=======================<br>
<a moz-do-not-send="true"
href="http://devblog.brahmancreations.com"
target="_blank">http://devblog.brahmancreations.com</a>
</div>
</div>
</div>
</div>
<br>
<fieldset></fieldset>
<br>
</div>
</div>
<div class="im">
<pre>--
_______________________________________________
Lazarus mailing list
<a moz-do-not-send="true" href="mailto:Lazarus@lists.lazarus.freepascal.org" target="_blank">Lazarus@lists.lazarus.freepascal.org</a>
<a moz-do-not-send="true" href="http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus" target="_blank">http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus</a>
</pre>
</div>
</blockquote>
<br>
</div>
<br>
--<br>
_______________________________________________<br>
Lazarus mailing list<br>
<a moz-do-not-send="true"
href="mailto:Lazarus@lists.lazarus.freepascal.org">Lazarus@lists.lazarus.freepascal.org</a><br>
<a moz-do-not-send="true"
href="http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus"
target="_blank">http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus</a><br>
<br>
</blockquote>
</div>
<br>
<br>
</div>
<div class="gmail_extra">This attitude which exists in the
Pascal community needs to end. I say Pascal not FreePascal
because when I examine a lot of free Delphi libraries I see
the same thing. Lots and lots of code and not a comment in
sight. It makes stuff needlessly difficult. The simple fact is
documentation is never going to happen because no one has time
to create it with separate tools, not even the people writing
the code themselves. Coding time is the best time for
documentation because that is when the intent of the code is
clear and fresh in the developers mind, and incurs minimal
additional cost. After all it takes barely a minute or two to
describe a function, and the same parsing tools compiling the
code can pull out the comments and create documentation stubs
if there is a need to flesh them out further, eg with examples
etc<br>
<br>
Even a lot of the funded open source libraries don't have the
resources to create proper documentation. If you take Delphi
for instance, since Turbo Pascal, Delphi 7 etc the quality of
documentation has gone down and these are companies that are
well funded.<br>
<br>
Instead of doing the simple thing a purist attitude has been
adopted which never does anyone any good.<br>
<br>
</div>
<div class="gmail_extra">It is time developers learn to treat
other developers as consumers not people who are supposed to
RTFC or RTFM. Developers are people who are supposed to put
parts together just by examining the function parameters and
the function descriptions rather than wade through loads of
procedure definitions and sample code full of similar sounding
and confusing names.<br>
</div>
<div class="gmail_extra"><br>
</div>
<div class="gmail_extra">Enough digression - if considered
carefully a comment about the purpose of an object belongs in
the object definition itself. Why should interrogation about
an object's purpose be handled by a whole subsystem of code
which has precisely nothing to do with the object, ie the
operating system, a help displaying program, a filename which
is the help document, as well as a search string which is the
object's name? Multiply that by the variety of help displaying
programs for each operating system, then by the number of
operating systems available then you can see how ridiculous
the whole concept is. Just bureaucracy piled on bureaucracy
and attachment to ill thought out convention and tradition.
There is never a direct link between an object and the help
display programs available on the operating system.<br>
<br>
There is a totally insane disconnect here. The Smalltalk guys
got it right.<br>
<br>
</div>
<div class="gmail_extra">There can be an options to strip the
comments out in the final deliverable just like the debugging
information.<br>
</div>
<div class="gmail_extra"><br>
-- <br>
Frank Church<br>
<br>
=======================<br>
<a moz-do-not-send="true"
href="http://devblog.brahmancreations.com">http://devblog.brahmancreations.com</a>
</div>
</div>
<br>
<fieldset class="mimeAttachmentHeader"></fieldset>
<br>
<pre wrap="">_______________________________________________
fpc-pascal maillist - <a class="moz-txt-link-abbreviated" href="mailto:fpc-pascal@lists.freepascal.org">fpc-pascal@lists.freepascal.org</a>
<a class="moz-txt-link-freetext" href="http://lists.freepascal.org/mailman/listinfo/fpc-pascal">http://lists.freepascal.org/mailman/listinfo/fpc-pascal</a></pre>
</blockquote>
<br>
</body>
</html>